Solution for Adobe Captivate 4 AS3 aggregated SWF not working on Latest Flash Player (10.1.102.64)

November 22, 2010

Solution for Adobe Captivate 4 AS3 aggregated SWF not working on Latest Flash Player (10.1.102.64)

Followers: 0 people
November 22, 2010

Solution:

  1. Close Adobe Captivate 4 and Aggregator if already running.
  2. Download the AggGenerator.zip from here and extract the AggGenerator.dll.
  3.  In the Captivate 4 installed folder search for the file “AggGenerator.dll
  4. Rename the file to “AggGenerator_old.dll”.
  5. Place the dll downloaded in step 2 into the installed folder of Captivate 4.
  6. Relaunch Captivate/ Aggregator and re-publish your project.

The published output generated in Step 6 will not have any issues while playing on the latest flash player.

Comments (12)
2011-05-26 16:00:05
2011-05-26 16:00:05

I’m having the oposite problem – Publishing a captivate 4 project in Flash 8 – these are not working on Flash 9, but will run when upgraded to Flash 10. Will publishing in Flash 9 resolve this?

Upgrading all companies computers to Flash 10 not easy.

Like
2010-12-02 21:03:01
2010-12-02 21:03:01

Not sure if this is related, but my flash output from Captivate 5 has recently stopped working in Chrome and Firefox with the latest Flash Player. You briefly see the loading screen appear and then nothing.

It still runs fine in IE and used to work fine too in Chrome and Firefox with older Flash players.

Any ideas?

Here’s the link: http://www.qa-distiller.com/movie

Like
(1)
>
Anonymous
's comment
2010-12-11 02:27:31
2010-12-11 02:27:31
>
Anonymous
's comment

I’ve experienced the same issue as well. .swf files are no longer playing in browsers after updating to the newest flash player. Anyone have any ideas on the fix for this?

Like
2010-11-23 07:08:02
2010-11-23 07:08:02

Nice to see regular updates coming our way for both Captivate 4 and Captivate 5. The last thing we want to do is have to wait till the next version of Cp to get issues like this fixed. Keep up the good work!

Like
2010-11-23 05:34:58
2010-11-23 05:34:58

[…] this link: Solution for Adobe Captivate 4 AS3 aggregated SWF not working on … Tags: agggenerator, aggregator, captivate, close-adobe, extract-the-agggenerator, file, […]

Like
2010-11-23 03:21:13
2010-11-23 03:21:13

This only applies to CP4 not CP5?

Like
(4)
>
Anonymous
's comment
2010-11-23 11:16:29
2010-11-23 11:16:29
>
Anonymous
's comment

Yes Graham, This is only for Captivate 4. Captivate 5 does not have this issue with the latest flash player.

Like
>
Anonymous
's comment
2010-12-14 12:08:15
2010-12-14 12:08:15
>
Anonymous
's comment

Yes this applies to only Cp4. Cp5 is healthy in this workflow.

Like
>
Ashwin Bharghav
's comment
2011-11-23 02:18:00
2011-11-23 02:18:00
>
Ashwin Bharghav
's comment

Ashwin, any idea what the problem with Captivate 5 SWFs playing could be? I can view the published agg file fine on my PC, but no one else can view the content.

Like
>
Anonymous
's comment
2011-11-28 06:48:00
2011-11-28 06:48:00
>
Anonymous
's comment

Hello Jamie,

This issue was only with Captivate 4 so if you are observing with Captivate 5 SWFs is it possible to share that with me? I can try it from my end. You can send it to viswanat@adobe.com

Thanks,
Vish

Like
2010-11-23 01:26:06
2010-11-23 01:26:06

Thanks for the fix, guys. This solved my problem and my content is live now.

Like
2010-11-23 00:37:12
2010-11-23 00:37:12

[…] This post was mentioned on Twitter by karannnnnnnnnnn3, AJ George. AJ George said: Solution for #AdobeCaptivate 4 AS3 aggregated SWF not working on Latest #Flash http://bit.ly/cj4AbT […]

Like
Add your comment