Solution for Adobe Captivate 4 AS3 aggregated SWF not working on Latest Flash Player (10.1.102.64)

Solution:

  1. Close Adobe Captivate 4 and Aggregator if already running.
  2. Download the AggGenerator.zip from here and extract the AggGenerator.dll.
  3.  In the Captivate 4 installed folder search for the file “AggGenerator.dll
  4. Rename the file to “AggGenerator_old.dll”.
  5. Place the dll downloaded in step 2 into the installed folder of Captivate 4.
  6. Relaunch Captivate/ Aggregator and re-publish your project.

The published output generated in Step 6 will not have any issues while playing on the latest flash player.

12 Responses

  1. Nice to see regular updates coming our way for both Captivate 4 and Captivate 5. The last thing we want to do is have to wait till the next version of Cp to get issues like this fixed. Keep up the good work!

  2. Not sure if this is related, but my flash output from Captivate 5 has recently stopped working in Chrome and Firefox with the latest Flash Player. You briefly see the loading screen appear and then nothing.

    It still runs fine in IE and used to work fine too in Chrome and Firefox with older Flash players.

    Any ideas?

    Here’s the link: http://www.qa-distiller.com/movie

    • I’ve experienced the same issue as well. .swf files are no longer playing in browsers after updating to the newest flash player. Anyone have any ideas on the fix for this?

  3. I’m having the oposite problem – Publishing a captivate 4 project in Flash 8 – these are not working on Flash 9, but will run when upgraded to Flash 10. Will publishing in Flash 9 resolve this?

    Upgrading all companies computers to Flash 10 not easy.

Leave a reply

Related